yes1111 (yes1111) wrote,
yes1111
yes1111

Categories:

Записки пингвиновода-любителя. Нет звука в Avidemux? Сейчас вылечим!



На днях я неожиданно столкнулся с сюрпирзом, который преподнес мне мой любимый видеоредактор Avidemux: после установки он воспроизводил файлы без звука. Причем наблюдалось это сразу на двух достаточно разных компьютерах: на ноутбуке у сына (Intel Core 2 Duo T7700, Mobile Intel PM965 Express Chipset, Scientific Linux 6.3 i686), и на десктопе у меня на работе (AMD Athlon 64 x2 6000+, NVIDIA nForce4, Scientific Linux 6.4 x86_64).

Если подобная неприятность случилась у вас, посмотрите меню Правка/Свойства/Звук. У меня на обоих компьютерах по умолчанию стояло AudioDevice: Dummy (!). Меняем его на Alsa, звук сразу должен появиться. Если на воспроизведение накладывается неприятное "тырканье" (лучше всего к этому подходит английское слово ripple), можно попробовать OSS. Только сначала надо включить его поддержку.

Для этого:
1. Открываем файл /etc/modprobe.d/dist-oss.conf.
2.. Раскомментируем в нем строку:
install snd-pcm /sbin/modprobe --ignore-install snd-pcm && /sbin/modprobe snd-pcm-oss && /sbin/modprobe snd-seq-device && /sbin/modprobe snd-seq-oss
3. Перезагружаемся.

А поддержка OSS нам все равно понадобится - например, если вдруг захотим поиграть в Quake 3 :)
Tags: linux, записки сумасшедшего
Subscribe

Recent Posts from This Journal

  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 0 comments